Requirements

getting-started

Updated on: November 24, 2018

WordPress powers over 30% of all websites and over 60% of all CMS platforms today. Because so many people rely on WordPress, the core developers must take a fairly conservative approach when deciding which versions of PHP to support. While understandable, one of the drawbacks is leaving millions of sites running legacy versions of PHP thereby creating massive security vulnerabilitiesboth for site owners and its users.

We believe that one of the best ways to make WordPress more secure is by requiring users to upgrade their systems as a prerequisite to using our plugins. With this in mind, the minimum requirements for WP Shopify are:

Minimum Requirements

  • PHP 5.6 or greater
  • WordPress 4.7 or greater
  • PHP memory_limit of 64 MB (256 MB if running into syncing timeout issues)
  • PHP max_execution_time of 100 (300 if running into syncing timeout issues)
  • Valid HTTPS certificate

 

Copied!